Delayed Calendar Syncs
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 18, 2019 - 13:23 EDT
Identified
We've identified an issue with our upstream provider, Google Calendar, that has caused us to pause all calendar syncing until Google is able to resolve the Google Calendar outage.

https://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=cc21ebe3962430b2e4ae2b52e3dde98f for more information from Google directly.
Posted 2 months ago. Jun 18, 2019 - 11:13 EDT
This incident affected: Syncing Services (Google - Calendar Sync).