Billing Info Changes Not Currently Possible
Incident Report for Contactually
Resolved
We're considering this issue resolved as the backup payment gateway is working correctly.
Posted 7 months ago. Nov 06, 2017 - 11:26 EST
Monitoring
We've fallen back to our backup payment gateway while our payment provider resolves their issue. Updating billing info should be possible again.
Posted 7 months ago. Nov 06, 2017 - 10:53 EST
Identified
Our payment provider has informed us that it's an issue with their Production Integrations portion of their services. We'll monitor their progress in resolving the issue and provide further information as we receive it.
Posted 7 months ago. Nov 06, 2017 - 10:22 EST
Investigating
We're investigating an issue with our Payment Gateway which is preventing users from updating their credit card details. We'll update as soon as we have more information.
Posted 7 months ago. Nov 06, 2017 - 09:49 EST