Zuora payment issues
Incident Report for Contactually
Resolved
The payment service has been restored.
Posted 6 months ago. Jan 11, 2018 - 15:33 EST
Monitoring
Our payment processor Zuora is having issues currently.
Posted 6 months ago. Jan 11, 2018 - 14:02 EST