Contact Search Performance Degradation
Incident Report for Contactually
Resolved
The search performance degradation has been resolved.
Posted 11 months ago. Oct 17, 2017 - 14:34 EDT
Identified
We've identified a performance degradation in our search functionality and a fix is being implemented.
Posted 11 months ago. Oct 17, 2017 - 14:24 EDT