Application Currently Unavailable
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 29, 2019 - 16:51 EDT
Monitoring
The issue has been resolved and we will continue to monitor.
Posted 4 months ago. Apr 29, 2019 - 16:47 EDT
Investigating
We're investigating an issue where https://app.contactually.com is not loading.
Posted 4 months ago. Apr 29, 2019 - 16:45 EDT
This incident affected: Client Applications (Web Application).