Contact Search Delay
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 09, 2017 - 15:08 EDT
Monitoring
We believe incident is resolved. We'll continue to monitor.
Posted about 1 month ago. Oct 09, 2017 - 14:57 EDT
Identified
We've identified a delay in contact searching and are currently implementing a fix.
Posted about 1 month ago. Oct 09, 2017 - 14:56 EDT