Site Availability Issue
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 05, 2017 - 16:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Sep 05, 2017 - 15:07 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Sep 05, 2017 - 14:58 EDT