Unable to Reach Plans Page
Incident Report for Contactually
Resolved
We've confirmed with our upstream provider that this issue is resolved.
Posted about 1 year ago. Nov 17, 2016 - 11:14 EST
Monitoring
We've resolved the issue with the billing components within Contactually through working with our upstream provider. We'll continue to monitor.
Posted about 1 year ago. Nov 17, 2016 - 11:02 EST
Identified
We've identified an issue with our billing provider, Zuora. They are working to resolve the issue. We will update as soon as we have more information and timeline on a fix.
Posted about 1 year ago. Nov 17, 2016 - 10:45 EST