Accounts Inaccurately Marked as Expired Trial
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 08, 2017 - 14:34 EST
Monitoring
The fix has been implemented and we're monitoring to make sure functionality has been restored for all users.
Posted 10 days ago. Nov 08, 2017 - 14:20 EST
Identified
We've identified an issue where some paying customers are seeing a notification that their account is expired when it is actually not. We're working to fix this issue now.
Posted 10 days ago. Nov 08, 2017 - 14:12 EST