Site Availability Issues
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 7 months ago. May 17, 2017 - 13:29 EDT
Monitoring
We've mitigated the performance issues and the app has returned to normal functionality. We'll continue to monitor.
Posted 7 months ago. May 17, 2017 - 11:54 EDT
Identified
We've identified an issue with our database that is causing performance and loading issues for the application. More updates to come.
Posted 7 months ago. May 17, 2017 - 11:31 EDT