Intermittent Site Unavailability Due to Global Internet Outage
Incident Report for Contactually
Resolved
The issue has been resolved. That said, we will continue to monitor the situation in case of a reoccurrence.
Posted about 1 year ago. Oct 22, 2016 - 12:37 EDT
Identified
We're monitoring a global internet outage that could be affecting a subset of our users. You may have trouble reaching Contactually, as well as many other sites all over the internet.

See http://money.cnn.com/2016/10/21/technology/ddos-attack-popular-sites/
Posted about 1 year ago. Oct 21, 2016 - 14:30 EDT