Slow Page Loads
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2017 - 17:08 EDT
Monitoring
Page loads have returned to normal levels. We'll continue to monitor and work with Amazon Web Services.
Posted about 1 month ago. Jul 17, 2017 - 16:25 EDT
Identified
We've identified an issue with our upstream provider, Amazon Web Services, that is causing slow page load times. We're working to mitigate the issue with them.
Posted about 1 month ago. Jul 17, 2017 - 16:17 EDT