Slow Page Loads
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 29 days ago. Jul 24, 2017 - 17:27 EDT
Monitoring
We've identified the cause and are monitoring the situation.
Posted 29 days ago. Jul 24, 2017 - 14:34 EDT
Identified
We've identified an issue causing slow page loads that we're currently looking into. More to come.
Posted 29 days ago. Jul 24, 2017 - 14:20 EDT