Composer Not Loading
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 8 days ago. Oct 10, 2017 - 12:09 EDT
Identified
We've identified an issue that is causing the email composer and ScaleMail to not load properly. We're currently implementing a fix.
Posted 8 days ago. Oct 10, 2017 - 12:01 EDT