Degraded Performance of Billing Functionality
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 2 months ago. Dec 13, 2017 - 18:03 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Dec 13, 2017 - 16:12 EST
Identified
Due do an issue with our upstream payment provider, some users may experience problems trying to select new plans, change existing plans, or update billing information in general. We'll update as soon as they've resolved their issue.

Full details can be found here: https://trust.zuora.com/incidents/d53wkt1151bh.
Posted 2 months ago. Dec 13, 2017 - 12:43 EST