Billing Changes Impaired
Incident Report for Contactually
Resolved
This incident has been resolved.
Posted 17 days ago. Nov 01, 2017 - 13:33 EDT
Monitoring
Billing changes are possible again in production, but we're continuing to monitor to ensure that stays the case.
Posted 17 days ago. Nov 01, 2017 - 12:17 EDT
Identified
Our upstream billing provider is having issues, which is preventing users from signing up for new plans, updating credit cards, etc. We'll provide more information as soon as they've resolved their issue. For more info: https://trust.zuora.com/incidents/fy7cqvjcgg73.
Posted 17 days ago. Nov 01, 2017 - 12:03 EDT